Installation failing to complete


#1

Hello, I am having the same issue with installing. I tried with and without the flags and have had no luck. The only error message that I see that is about creating the database.


Installing on EC2 - Installer Did Not Complete
#2

I’ve moved to a separate topic since it’s unrelated to the EC2 one.

First, this is different to the error you were having in the git issue you created.

Is this the same installation?

Can you please provide some more details about your installation.

  • hosting provider
  • is this a new server??
  • what o/s is this
  • how much ram and free space on the server
  • what SMTP provider are you using

If the server is not new, what other services are you running?

From the error above, it looks very much like your SMTP credentials are wrong.


#3

Hello,
I am having the same issue as i was before. After a while i am just getting a standard error message saying that installation failed so i was trying to see if the log would tell me what was happening. I am hosting the server myself and it is a brand new server running ubuntu 14.04. 4gb ram and 16gb free space. I was using google as the SMTP provider.


#4

You won’t be able to use Google’s SMTP - I believe that requires configuration. Please use one of the ones we recommend. I believe using their SMTP server like this will get your account blocked.

That would most probably explain your SMTP errors.

The first error - can you run the installer again in the foreground and send over the logs (once you’ve changed to an alternative SMTP provider).


#5

I ran the installer again with the sendgrid smtp server instead like you recommended and i was able to get to the config page through the browser now but only through http not https. It appears that it is struggling with the certificate creation part of the install cause when i ctrl c the terminal then it goes to the Starting MIMO. Please wait while the installation completes…
If this is the first time you’ve installed MIMO, it may take a few minutes to generate your keys then getting the same error message.